Spyware Process Detector - Руководство пользователя программы

Версия 3.23 ( 18 сентября 2012 года )
Copyright (C) 2006-2012, System SoftLab.

Об ошибках и пожеланиях пишите
spydetector@systemsoftlab.com

Посетите наш сайт и скачайте последнюю версию
www.systemsoftlab.com

Spyware Process Detector показывает пользователю на экран список запущенных процессов и список процессов автозапуска. Обнаруживает любые скрытые процессы, такие как шпионы, трояны, вирусы и СМС блокираторы. Препятствует проникновению в систему СМС блокираторов. Используется 17 методов обнаружения скрытых процессов. Каждый процесс оценивается программой по степени опасности. Опасные и скрытые процессы выделяются красным цветом. Пользователь сам решает удалить этот процесс или оставить его, пометив как "безопасный". Данная программа нужна для определения новых (ещё неизвестных вашей антивирусной программе) вирусов, троянов и шпионов. Рекомендуется использовать вместо стандартного диспетчера задач вместе с вашей антивирусной программой.

Это бесплатная ПРОБНАЯ версия. Вы можете использовать её только 14 дней. Полная версия стоит 290 рублей. Вы платите только один раз, все следующие обновления бесплатны. По истечению срока Вы должны купить эту программу или удалить её с компьютера. Чтобы купить программу нажмите здесь, при этом у Вас должно быть установлено соединение с Интернетом.

Мы принимаем любые виды оплаты: СМС сообщения, банковские переводы, пластиковые карточки, платежные системы и т.д. Вы можете просто послать СМС на короткий номер или напечатать бланк и оплатить в ближайшем отделение СберБанка. Подробнее здесь www.systemsoftlab.com/r_purchase_spydetector.html

  • Операционная система Microsoft Windows 2000/XP/2003/Vista/2008/7/8 x86/x64.
  • Процессор Intel Pentium или выше (Рекомендуется Intel Pentium II 500 MHz или выше)
  • Оперативная память 32Mb или больше (Рекомендуется 128Mb или больше)
  • 3Mb на жёстком диске
  1. Лицензионное соглашение
  2. Как купить программу
  3. Анализ запущенных процессов
  4. Анализ записей автозапуска процессов
  5. Сохранение и загрузка процесса
  6. Описание настроек программы
  7. Описание версий программы
  8. Пишите нам
Copyright (C) 2006-2012, System SoftLab.
Дата последнего обновления
18 сентября 2012 года


  1. Это лицензионное соглашение является юридическим соглашением между Вами и автором этой программы.
  2. Устанавливая или используя эту программу, Вы полностью соглашаетесь с этим соглашением. Если Вы не согласны с условиями этого Соглашения, Вы не можете устанавливать или использовать эту программу, и должны удалить все файлы программы из своих компьютеров.
  3. Данная версия программы является бесплатной ПРОБНОЙ. Вы можете использовать её только 14 дней. По истечению срока Вы должны купить эту программу или удалить её с компьютера. Лицензия на использование полной версии стоит 290 рублей.
  4. Автор не несёт никакой ответственности за порчу и потерю информации.
  5. Вы можете выпускать эту редакцию программы на CD с другими программами (то есть, на сборниках программ), но только в оригинальном установочном архиве и без ключей и паролей.
  6. Вы можете выкладывать эту редакцию программы на своем интернет сайте, но только в оригинальном установочном архиве без ключей и паролей, и если доступ к сайту бесплатен для пользователей.
  7. Вы можете передавать эту редакцию программы вашим друзьям и другим людям, но только в оригинальном установочном архиве без ключей и паролей.
  8. Вы не имеете права передавать ключи и пароли другим лицам, выкладывать их на интернет сайте.
  9. Вы не можете дизассемблировать или переделывать любую часть этой программы.
  10. Запрещается использовать эту программу в коммерческих целях без согласия автора. "В коммерческих целях" означает для получения денежной или прочей материальной выгоды. Вы не можете арендовать, передавать в аренду или продавать эту программу.
  11. Только зарегистрированные пользователи, купившие программу, могут получить техническую поддержку по электронной почте.
  12. Автор имеет право отменить лицензию в случае нарушения пользователем любого пункта данного соглашения.

Copyright (C) 2006-2012, System SoftLab.
Дата последнего обновления


Это бесплатная ПРОБНАЯ версия. Вы можете использовать её только 14 дней. Полная версия стоит 290 рублей. Вы платите только один раз, все следующие обновления бесплатны. По истечению срока Вы должны купить эту программу или удалить её с компьютера. Чтобы купить программу нажмите здесь, при этом у Вас должно быть установлено соединение с Интернетом. Для зарегистрированных пользователей полная техническая поддержка по электронной почте.

Мы принимаем любые виды оплаты: СМС сообщения, банковские переводы, пластиковые карточки, платежные системы и т.д. Вы можете просто послать СМС на короткий номер или напечатать бланк и оплатить в ближайшем отделение СберБанка. Подробнее здесь www.systemsoftlab.com/r_purchase_spydetector.html

Copyright (C) 2006-2012, System SoftLab.
Дата последнего обновления


Анализ запущенных процессов

Для начала работы с программой следует нажать кнопку "Сканировать". Программа начнёт анализ системы и поиск процессов, на экране появится процентная шкала сканирования. Когда сканирование системы будет завершено, то в основной таблице программы Вы увидите список процессов в системе. Процессы будут отсортированы по статусу (оценке степени опасности). Для каждого процесса в таблице будут показаны его основные характеристики, такие как идентификатор, идентификатор процесса родителя, имя файла, название компании, описание и заголовок основного окна процесса.

Каждый процесс оценивается программой по степени опасности и процессу присваивается статус. Опасные и скрытые процессы выделяются красным цветом. Подозрительные процессы жёлтым цветом. Не все красные и жёлтые процессы вирусы/шпионы, они могут использовать похожие вирусные технологии. Ваша основная задача определить по статусу и характеристикам процесса безопасный это процесс или нет. В текущей версии программы присваиваются следующие статусы:
  • Опасен - процесс скрывается или использует вирусные/шпионские технологии. На картинке выше вы можете увидеть процесс hijack.exe, это как раз шпион и похититель паролей. Обычно поле "Компания" у таких процессов пустое, но никто не мешает прописать туда любое имя.
  • Изменен - У процесса изменилась контрольная сумма или в процессе созданы потоки и исполняется код чужого процесса, такой процесс потенциально опасен. Подробности о созданных потоках можно увидеть в информации о процессе. Контрольная сумма системного процесса может меняться при установке пакетов обновлений или хотфиксов Windows.
  • Подозрительный - процесс не имеет видимых окон и иконок, только драйвера (утилиты для устройств) могут не иметь видимых окон. На картинке выше вы можете увидеть множество подозрительных процессов. Большинство их них драйвера. Процессы компании Advanced Micro Devices - это драйвера материнской платы. Процессы компании C-Media Electronic - это драйвера аудио карты. Процессы компании NVIDIA Corporation - это драйвера видеокарты. Процессы компании Lexmark International - это драйвера принтера. Обратите внимание, процесс LEXPPS.EXE драйвер принтера Lexmark, но поле "Компания" у него не проставлена. Единственный подозрительный процесс не являющийся драйвером - GoogleToolbarNotifier.exe, это программа для обновления плагина Google Toolbar для Internet Explorer, если Вам такое обновление не нужно его можно удалить.
  • Удалён - процесс удалён, но запись о нём всё ещё присутствует в операционной системе.
  • Обычный - процесс имеет видимые окна и не использует опасные и подозрительные технологии.
  • Системный - системный процесс, без которого система не будет работать правильно, должен быть подписан компанией Microsoft.
  • Безопасен - процесс помечен пользователем как безопасный.
  • Полезный - процесс присутствует в базе полезных программ.
Для получения более подробной информации о процессе просто сделайте двойной щелчок правой клавиши мыши по строке с нужным процессом. Или выберите из контекстного меню - пункт "Информация о процессе" и появится окно информации о процессе.

Из окна "Информация о процессе" или из контекстного меню Вы можете выполнить следующие действия над процессом:

Информация о процессе - Вызвать окно информации о процессе.
Пометить как Безопасный - Пометить процесс как безопасный.
Проверить этот файл на вирусы через Virustotal.com - Для отправки файла на Virustotal.com, Вы должны один раз загрузить и установить VirusTotal Uploader. Это бесплатная программа vtsetup.exe размером всего 80KB. Страница загрузки программы www.virustotal.com/metodos.html.
Добавить процесс в автозапуск - Добавить процесс в автозапуск при старте системы или входе пользователя.
Установить приоритет - Установить приоритет процесса из списка.
Держать приоритет - При установке данной галочки, программа удерживает выбранный вами приоритет процесса. Настройка сохраняется при перезапуске программы и Windows.
Остановить процесс - Полностью прекращает выполнение выбранного процесса (делает паузу в работе процесса до команды "Продолжить процесс").
Продолжить процесс - Продолжает выполнение выбранного процесса.
Сохранить процесс - Полностью сохраняет процесс на диск, включая память и системное окружение.
Загрузить процесс - Загружает сохраненный ранее процесс из указанного файла.
Удалить процесс - Удаляет процесс. Будьте внимательны, при удалении системного процесса, Операционная система может зависнуть!
Удалить процесс и его файл - Удаляет процесс и его запускной файл. Будьте внимательны, не удалите нужные файлы! Не удаляйте системные файлы и драйвера! Операционная система может перестать загружаться!
Блокировать запуск процесса по имени файла - Блокировка работает постоянно, даже когда SPD не запущен или удален. Будьте внимательны, не блокируйте системные файлы и драйвера! Посмотреть и отредактировать список заблокированных процессов можно через меню "Команды" -> "Список заблокированных процессов".
Блокировать запуск процесса по полному пути - Блокировка работает, только если запущен SPD. Будьте внимательны, не блокируйте системные файлы и драйвера! Посмотреть и отредактировать список заблокированных процессов можно через меню "Команды" -> "Список заблокированных процессов".

Copyright (C) 2006-2009, System SoftLab.
Дата последнего обновления
3 октября 2009 года


Анализ записей автозапуска процессов

После того как Вы обработаете список запущенных процессов ( пометите процессы как безопасные) перейдите в закладку автозапуска, где Вы увидите список записей автозапуска процессов в системе. Записи будут отсортированы по статусу (оценке степени опасности). Для каждой записи в таблице будут показаны его основные характеристики, такие как название, тип, имя файла, состояние, название компании и описание.

Каждая запись автозапуска оценивается программой по степени опасности и записи присваивается статус. Опасные и скрытые записи выделяются красным цветом. Подозрительные записи жёлтым цветом. Не все красные и жёлтые записи принадлежат процессам вирусам/шпионам, они могут использовать похожие вирусные технологии. Ваша основная задача определить по статусу и характеристикам записи безопасный запускаемый процесс или нет. В текущей версии программы записям автозапуска присваиваются следующие статусы:
  • Опасен - запись и/или процесс скрываются или использует вирусные/шпионские технологии. На картинке выше вы можете увидеть запись hijack, это как раз шпион и похититель паролей. Обычно поле "Компания" у таких процессов пустое, но никто не мешает прописать туда любое имя.
  • Изменен - у процесса или файла изменилась контрольная сумма или в процессе созданы потоки и исполняется код чужого процесса, такой процесс потенциально опасен. Контрольная сумма системного процесса может меняться при установке пакетов обновлений или хотфиксов Windows.
  • Подозрительный - процесс автозапуска похож на вредоносный или процесс не имеет видимых окон и иконок, только драйвера (утилиты для устройств) могут не иметь видимых окон. На картинке выше вы можете увидеть множество подозрительных записей. Большинство их них драйвера. Записи компании Advanced Micro Devices - это драйвера материнской платы. Записи компании C-Media Electronic - это драйвера аудио карты. Записи компании NVIDIA Corporation - это драйвера видеокарты. Записи компании Lexmark International - это драйвера принтера. Единственная подозрительная запись на файл не являющийся драйвером - swg, это программа для обновления плагина Google Toolbar для Internet Explorer, если Вам такое обновление не нужно её можно удалить.
  • Обычный - запись не вызывает подозрений, процесс имеет видимые окна и не использует опасные и подозрительные технологии.
  • Системный - системный процесс, без которого система не будет работать правильно, должен быть подписан компанией Microsoft.
  • Безопасен - запись или процесс помечен пользователем как безопасный.
  • Полезный - процесс присутствует в базе полезных программ.
  • Новый - запись автозапуска обнаружена впервые. Запись может иметь одновременно статус "Новый" и любой другой из этого списка. Полный статус смотрите в окне информации о записи.
Для получения более подробной информации о записи просто сделайте двойной щелчок правой клавиши мыши по строке с нужной записью. Или выберите из контекстного меню - пункт "Информация о записи" и появится окно информации о записи.

Из окна "Информация о записи" или из контекстного меню Вы можете выполнить следующие действия над записью:

Информация о записи - Вызвать окно информации о записи.
Информация о процессе - Вызвать окно информации о процессе, если процесс запущен.
Пометить как Безопасный - Пометить запись и процесс как безопасный.
Проверить этот файл на вирусы через Virustotal.com - Для отправки файла на Virustotal.com, Вы должны один раз загрузить и установить VirusTotal Uploader. Это бесплатная программа vtsetup.exe размером всего 80KB. Страница загрузки программы www.virustotal.com/metodos.html.
Запустить новый процесс - Запускает исполняемый файл записи автозапуска.
Добавить запись - Добавить файл в автозапуск при старте системы или входе пользователя.
Удалить запись - Удаляет запись. Будьте внимательны, не удалите нужные файлы! Не удаляйте системные файлы и драйвера! Операционная система может перестать загружаться!
Удалить запись и файл - Удаляет запись и запускной файл. Будьте внимательны, не удалите нужные файлы! Не удаляйте системные файлы и драйвера! Операционная система может перестать загружаться!
Блокировать запуск процесса по имени файла - Блокировка работает постоянно, даже когда SPD не запущен или удален. Будьте внимательны, не блокируйте системные файлы и драйвера! Посмотреть и отредактировать список заблокированных процессов можно через меню "Команды" -> "Список заблокированных процессов".
Блокировать запуск процесса по полному пути - Блокировка работает, только если запущен SPD. Будьте внимательны, не блокируйте системные файлы и драйвера! Посмотреть и отредактировать список заблокированных процессов можно через меню "Команды" -> "Список заблокированных процессов".

Copyright (C) 2006-2009, System SoftLab.
Дата последнего обновления
3 октября 2009 года


Сохранение и загрузка процесса

Нельзя перезапускать процесс. Для больших игр действует только внутри одного уровня. Пока работает не на всех играх, может повесить игру.

Данная функция может использоваться для сохранения игр, где это не предусмотрено. SPD сохраняет память процесса и его системное окружение. Windows всячески пытается сопротивляться, поэтому возможны сбои в процессе. Если произошел сбой, то обычно процесс просто закрывается.

Имеются три дополнительных режима работы (устанавливаются в настройках). При включении каждого, SPD начинает вмешиваться в работу процесса с момента сохранения, чтобы увеличить вероятность успешной загрузки. Однако, не все процессы переживают такое вмешательство. В случае, если обычным способом не получилось загрузить, можно пытаться тогда использовать эти режимы, перебирая их по очереди:

  • Режим 1 - Отвечает за управление виртуальной памятью.
  • Режим 2 - Отвечает за управление кучей памяти.
  • Режим 3 - Отвечает за управление системными объектами.

    Внимание! Запомните следующее:

  • Больше шансов на успешную загрузку, если отключить музыку и звуки.
  • Если вы сохраняетесь, когда игра свернута, то и грузитесь только тогда, когда она свернута.

    Присылайте нам название игр, в которых не получилось сохраниться, и в которых получилось тоже. Обязательно пишите версию Windows и настройки режимов.

    Copyright (C) 1996-2007, System SoftLab.
    Дата последнего обновления
    3 октября 2007 года


Описание настроек программы

  • Язык интерфейса - вы можете выбрать один из установленных языковых плагинов.
  • Руководство пользователя - вы можете выбрать одно из установленных руководств пользователя.
  • Интервал обновления - интервал обновления информации о процессах в миллисекундах. Для медленных компьютеров лучше ставить больше. Минимум 50 миллисекунд.
  • Стартовать при запуске Windows - программа стартует, как и стандартный Диспетчер задач, только с видимой иконкой загрузки процессора.
  • Заменить стандартный Диспетчер Задач - при установке этой галочки SPD будет вызываться вместо стандартного Диспетчера Задач.
  • Обновлять информацию о процессах - при выключении, программа не будет следить, какие процессы завершились или появились.
  • Сворачивать окно при закрытии - при закрытии окна программа свернётся и будет доступна в системном треи.
  • Показать загрузку процессора для процесса System Idle - загрузка системного процесса System Idle показывает простой процессора в процентах. Поэтому правильнее её не учитывать.
  • Показать процессорное время для System Idle - процессорное время системного процесса System Idle показывает время простоя процессора. Поэтому правильнее его не учитывать.

  • Отображать процессы - выберите статусы процессов, которые будут показаны в таблице. Если процессов много, удобнее отключить показ системных процессов.
  • Использовать свои функции для открытия процесса - при установке галочки лучше обнаруживает скрытые процессы и его характеристики.
  • Использовать свои функции для удаления процесса - при установке галочки больше возможности для удаления процесса.
  • Использовать свои функции для чтения/записи памяти процесса - при установке галочки читает/пишет память защищенных процессов.

  • Фоновое сканирование системы - SPD постоянно сканирует систему и при обнаружении опасных процессов всплывает поверх других окон.
  • Следить за новыми записями автозапуска - SPD постоянно сканирует систему и при обнаружении новых записей автозапуска всплывает поверх других окон.
  • Сканировать при старте программы - при установке этой галочки SPD будет сканировать процессы сразу после своего старта.
  • Следить за изменениями потоков и кода процессов - при установке этой галочки SPD постоянно сканирует систему и анализирует потоки и код процессов.

  • Выберите колонки для показа - Конструктор таблицы процессов. Можно менять положение колонок в таблице и их видимость. Кнопки со стрелками передвигают колонку по списку.

  • Выберите колонки для показа - Конструктор таблицы записей автозапуска. Можно менять положение колонок в таблице и их видимость. Кнопки со стрелками передвигают колонку по списку.

    Copyright (C) 2006-2008, System SoftLab.
    Дата последнего обновления
    10 декабря 2008 года


Описание версий программы

  • Полная поддержка для операционных систем Microsoft Windows 8 и Windows Server 2012.
  • Изменена страница загрузки VirusTotal Uploader 2.0
  • Исправлена ошибка с вылетом программы при заходе в личный кабинет антивируса Касперского.
  • Исправлены ошибки с вылетом в Windows XP SP3 и Windows 2008 R2.
  • Исправлены многие ошибки.
  • Добавлена команда "Задать соответствие по ядрам", где вы можете указать какие ЦП (ядра) разрешено использовать выбранному процессу.
  • Добавлена галочка "Запомнить это соответствие и всегда следовать ему". При установке данной галочки, программа удерживает выбранное вами соответствие по ядрам для каждого процесса. Настройка сохраняется при перезапуске программы и Windows.
  • Добавлена поддержка VirusTotal Uploader 2.0. Это новая версия бесплатной программы для проверки файлов на вирусы через Virustotal.com.
  • Вместо файла ключа и паролей теперь используется один регистрационный код, что упрощает процедуру регистрации программы. Кроме того, в последнее время многие почтовые системы, в том числе gmail.com, считают письмо с файлами спамом и удаляют письмо или файл ключ, в результате покупатель остается без ключа.
  • Обновлены базы полезных программ.
  • Исправлены многие ошибки.
  • Добавлена опция "Автоматически удалять опасные объекты автозапуска", по умолчанию включена. Специально для борьбы с блокираторами, требующих послать СМС. При включенном SPD блокиратор не сможет заблокировать компьютер после перезагрузки.
  • Переделан режим "Поверх всех окон", он стал более устойчив против блокираторов (Trojan.Winlock).
  • Добавлен новый признак подозрительного процесса - "Название файла процесса похоже на системное".
  • Теперь в случае, если процесс не получается удалить, программа предложит заблокировать запуск процесса по имени и перегрузиться.
  • Исправлены многие ошибки.
  • Полная поддержка для Windows 7 RC (Build 7100) и Windows 7 RTM (Build 7600).
  • Теперь программа обнаруживает и показывает скрытые потоки, в том числе в скрытых процессах, а также корректно может удалить их.
  • В закладку "Потоки" добавлена галочка "Получить информацию о потоках из структуры ядра ETHREAD". А также добавлено поле ETHREAD в таблицу потоков.
  • В таблицу процессов добавлено поле EPROCESS, это структура ядра уникальна для каждого процесса.
  • При запуске DLL через Rundll32.exe, теперь в имени файла процесса будет путь к DLL, а не к Rundll32.exe.
  • Исправлена ошибка при работе на Windows Vista/2008 без установленного Service Pack.
  • Исправлена ошибка при работе в режиме "Поверх всех окон".
  • Исправлена ошибка приводящая к синему экрану на Windows XP и Vista.
  • Добавлена встроенная база полезных программ, в дальнейшем она будет обновляться автоматически через интернет. Дату последнего обновления базы можно посмотреть в окне "О программе". Процессы со статусом системный, безопасный и полезный теперь рисуются разными оттенками зеленого.
  • Улучшен алгоритм определения статуса. Улучшено обнаружение скрытых процессов для Windows Vista/2003/2008.
  • Добавлена команда "Проверить этот файл на вирусы через Virustotal.com". Для отправки файла на Virustotal.com, Вы должны один раз загрузить и установить VirusTotal Uploader. Это бесплатная программа vtsetup.exe размером всего 80KB. Страница загрузки программы www.virustotal.com/metodos.html.
  • Добавлена команда "Запустить новый процесс" в меню "Команды".
  • Добавлена команда "Блокировать запуск процесса по имени файла". Блокировка работает постоянно, даже когда SPD не запущен или удален.
  • Добавлена команда "Блокировать запуск процесса по полному пути". Блокировка работает, только если запущен SPD.
  • Посмотреть и отредактировать список заблокированных процессов можно через меню "Команды" -> "Список заблокированных процессов".
  • Убрана настройка "Следить за изменениями потоков и кода процессов". Больше анализ поведения потоков не делаем.
  • Исправлена ошибка, когда при удалении программы оставался сервис, который не стартовал и писал ошибку в системный лог.
  • Исправлена ошибка с неправильным отображением форм при размере шрифта не равным стандартному 96 dpi. Например, часто для ноутбуков используют 120 dpi.
  • Исправлена ошибка приводящая к синему экрану на Windows XP на многоядерных процессорах.
  • Исправлена ошибка приводящая к синему экрану на Windows 2003 Service Pack 2.
  • Исправлена ошибка при работе в Windows XP без админских прав.
  • Поддержка Windows Server 2008 и Windows 7 Beta.
  • Фоновое сканирование системы теперь меньше загружает процессор.
  • Устранен конфликт с Agnitum Outpost Firewall последних версий.
  • Теперь программа умеет открывать защищенные процессы в Windows Vista/2008/7 x86, то есть умеет получать все атрибуты защищенного процесса и удалять его.
  • Добавлена команда "Держать приоритет процесса". При установке данной галочки, программа удерживает выбранный вами приоритет процесса. Настройка сохраняется при перезапуске программы и Windows.
  • Добавлена характеристика процесса и колонка "Впервые найдено". Содержит дату и время первого обнаружения процесса или записи автозапуска.
  • Исправлена ошибка при подсчёте контрольной суммы процессов на Windows Vista.
  • Исправлена ошибка с определением приоритета скрытого процесса.
  • Поддержка для операционных систем Microsoft Windows XP/2003/Vista x64. Программа запускается в режиме "без сервиса" и работают только 7 методов обнаружения скрытых процессов.
  • Переименованы объекты в программе и имена файлов. Так как появились трояны, которые ищут и блокируют SPD по имени.
  • Исправлена ошибка при работе на Windows Vista без установленного Service Pack.
  • Добавлен чешский языковой плагин.
  • Добавлена колонка "Средняя загрузка процессора". Эта колонка показывает среднюю загрузку процессора в процентах с момента запуска процесса. Для удобства просмотра, загрузка менее одной сотой процента считается нулевой. Отсортируйте по этой колонке и узнаете процессы, которые используют много времени процессора.
  • Исправлены многие ошибки.
  • На главную форму добавлена закладка "Автозапуск", для отображения всех записей автозапуска процессов в системе. Каждая запись автозапуска оценивается программой по степени опасности (безопасный, системный, подозрительный, опасный, обычный). Добавлено контекстное меню для работы с автозапуском. Вы можете посмотреть подробную информацию о записи, удалить или создать новую запись.
  • Добавлена форма "Информация о записи" с подробной информацией о записи автозапуска, включая Место записи, Имя записи, Имя файла запуска, Значение, Статус, Причина статуса, Дата и Время первого обнаружения, а также полная информация из подписи файла запуска.
  • Добавлены галочка в настройки "Следить за новыми записями автозапуска" и выбор "Всплыть, если обнаружена запись автозапуска со статусом". Если включено, то при обнаружении новых или опасных записей автозапуска SPD всплывает поверх других окон.
  • Улучшен алгоритм определения статуса. Исправлены ошибки.
  • Теперь мы принимаем оплату через СМС сообщения. Чтобы оплатить программу, просто отправьте СМС сообщение на короткий номер. Это доступно всем и очень просто! Чтобы оплатить программу СМС сообщением нажмите здесь.
  • Теперь программа определяет правильно размер используемой памяти и время работы скрытых процессов.
  • В настройки добавлена опция "Следить за изменениями потоков и кода процессов". По умолчанию галочка выключена.
  • Исправлена ошибка с зависанием при зацикливании, какого либо процесса (когда он постоянно запускает сам себя).
  • Исправлена ошибка, когда процесса уже нет, но в списке активных процессов он ещё присутствует.
  • Добавлена колонка "Максимальный размер памяти". Эта колонка показывает, сколько максимум памяти использовал процесс. Это может помочь увеличить скорость вашей системы, если Вы знаете процессы, которым нужно много памяти.
  • Добавлена колонка "Процессорное время". Эта колонка показывает, сколько времени этот процесс использовал процессор с нагрузкой 100%. Вы можете узнать процессы, которые используют много времени процессора.
  • Добавлена возможность включить/отключить в настройках показ процессорного времени для процесса System Idle (на самом деле процессорное время этого системного процесса показывает время простоя процессора).
  • Добавлена колонка "Домен пользователя".
  • Исправлены многие ошибки.

  • Поддержка немецкого языка. Добавлен немецкий языковой плагин. Спасибо за перевод Oliver Sahr. При установке программы теперь можно выбрать язык интерфейса.
  • Добавлены команды Сохранить и Загрузить процесс. Может использоваться для сохранения игр, где это не предусмотрено. Подробнее читайте в руководстве пользователя. В бесплатной пробной версии загрузить процесс можно только три раза.
  • В окне Хэндлы добавлена возможность установить фильтр по типу.
  • Исправлены ошибки.

  • При пометке процесса как безопасного или системного сохраняется имя пользователя, дата и время пометки. Их можно посмотреть в причине статуса в окне информации о процессе.
  • При изменении контрольной суммы системного процесса, его можно пометить опять как системный. Контрольная сумма системного процесса может меняться при установке пакетов обновлений или хотфиксов Windows.
  • Теперь программа нормально работает без администраторских прав. Но для установки они нужны обязательно.
  • Исправлена ошибка с зависанием в Windows XP.
  • Оптимизация использования памяти.
  • Улучшен анализ потоков.

  • Улучшен алгоритм определения статуса. Исправлены ошибки.

  • Добавлено фоновое сканирование системы. При обнаружении опасных процессов SPD всплывает поверх других окон.
  • В настройки добавлена закладка "Сканирование". На этой закладке галочки "Фоновое сканирование системы" и "Сканировать при старте программы". А также Вы можете выбрать на обнаружение, какого типа процесса нужно всплывать.
  • Добавлены новые настройки "Использовать свои функции для чтения и записи памяти процесса".
  • Исправлены ошибки.

  • Добавлены новые методы определения вредосных процессов. Теперь SPD умеет выявлять шпионов маскирующихся под системные процессы.
  • При определении системного и безопасного статуса теперь учитывается контрольная сумма процесса. Если у системного или безопасного процесса меняется контрольная сумма, то такой процесс получает статус "Изменен" и выделяется красным.
  • В базу программы добавлены контрольные суммы процессов. База теперь кодируется и недоступна для внешнего редактирования.
  • В список окон добавлены колонки: Свёрнутое, Позиция по X, Позиция по Y.

  • В меню добавлена команда "Поверх всех окон". При установке окно SPD будет поверх всех окон в системе.
  • Добавлена опция "Заменить стандартный Диспетчер Задач". При установке этой галочки SPD будет вызываться вместо стандартного Диспетчера Задач.
  • Добавлена опция "Сканировать при старте программы". При установке этой галочки SPD будет сканировать процессы сразу после своего старта.

  • Добавлена возможность включить/отключить в настройках показ загрузки процессора для процесса System Idle (на самом деле загрузка этого системного процесса показывает простой процессора в процентах).
  • Общая загрузка процессора теперь пишется внизу в статусной строке главного окна.
  • Исправлена ошибка с определением модуля окна.
  • Исправлена ошибка с утечкой памяти.

  • Новая форма информации о процессе. Спасибо за помощь в разработке Oliver Sahr. Форма содержит пять закладок с информацией о процессе. Всё что, можно узнать о процессе. Основные атрибуты на первой закладке. Добавлены кнопки "Копировать информацию в буфер обмена" и "Открыть информацию о процессе родителе".
  • По многочисленным просьбам, в окне информации добавлена причина получения статуса. Добавлены иконки выбранного процесса и процесса родителя. А также добавлены поля: Контрольная сумма, Версия, Права, Торговые марки, Язык.
  • Закладка "Окна" содержит подробную информацию об окнах процесса (заголовок, класс, родитель, модуль, видимость, активность). Любое окно можно сделать видимым или невидимым, сделать активным, уничтожить. И специальная функция для изменения заголовка окна.
  • Закладка "Потоки" содержит подробную информацию о потоках процесса (ID потока, Время создания, Адрес старта, Приоритет, Текущее состояние, Причина ожидания исполнения, Количество переключений потока, Время исполнения в ядре и в пользовательском режиме). Любой поток можно остановить или продолжить, уничтожить, а также изменить приоритет исполнения.
  • Закладка "Модули" содержит подробную информацию о модулях загруженных в процесс (имя модуля, имя файла, адрес загрузки, размер, точка входа, компания и описание).
  • Закладка "Хэндлы" содержит подробную информацию о хендлах процесса (тип, имя, адрес). Здесь можно увидеть все файлы, драйвера или каналы открытые процессом. А также, с какими устройствами и ветками реестра работает процесс.
  • Исправлена ошибка при первом запуске программы в Windows XP.

  • Улучшено обнаружение Rkdemo Rootkit и других Rootkit процессов.
  • Добавлены французский и болгарский плагин.
  • Исправлены ошибки.

  • Улучшено обнаружение скрытых процессов. Новый метод обнаружения.
  • Добавлены колонки "Имя пользователя" и "Имя процесса родителя" (по умолчанию они отключены).
  • Теперь работает показ загрузки процессора для скрытых процессов.
  • Добавлена новая настройка "Использовать свои функции для открытия процесса". При установке галочки лучше обнаруживает скрытые процессы и его характеристики.
  • Добавлена новая настройка "Использовать свои функции для удаления процесса". При установке галочки больше возможности для удаления процесса.

  • Сделано обновление таблицы процессов. Интервал обновления можно поменять в настройках. Программа следит, какие процессы завершились или появились.
  • Добавлены колонки "Загрузка процессора", "Размер памяти", "Время работы", "Приоритет".
  • Добавлен конструктор таблицы процессов. Можно менять положение колонок в таблице и их видимость.
  • Добавлена команда "Установить приоритет" для установки приоритета процесса.
  • Новая иконка в трей, похожая на стандартный Диспетчер задач со шкалой загрузки процессора. При наведении мыши на иконку, показывает имя процесса наиболее загрузившего систему.
  • Добавлена настройка "Стартовать при запуске Windows". Стартует, как и стандартный Диспетчер задач, только с видимой иконкой загрузки процессора.
  • Период пробного использования увеличен до 14 дней.
  • Исправлены ошибки.

  • Полная поддержка для операционной системы Microsoft Windows Vista x86. При первом запуске SPD в Vista необходимо для установки сервиса ввести пароль локального администратора (пользователь Administrator). Или запустить программу через контекстное меню "Run As Administrator" ( в русской версии "Запустить от имени Администратора" ).

  • Совместный режим работы с программой ArtMoney версии 7.23 или выше.
  • Команда "Сохранить в Excel" (сохраняет список процессов в Excel).
  • Исправлена ошибка с переустановкой программы в другой каталог.

  • Процессы в таблице рисуются разными цветами в зависимости от степени опасности.
  • Пользователь может пометить процесс как опасный или безопасный, список сохраняется при перезапуске программы.
  • Улучшены методы обнаружения процессов. Всего 16 методов обнаружения процессов и 2 дополнительных метода для получения характеристик процесса.
  • Добавлен статус программы "Удалён" (процесс удалён, но запись о нём всё ещё присутствует в операционной системе).
  • Добавлен статус программы "Изменен" (в процессе созданы потоки и исполняется код чужого процесса, такой процесс потенциально опасен).
  • Полная поддержка для Windows Server 2003.
  • Ограниченная поддержка для Windows 95/98. Обнаружение опасных процессов работать в этих ОС не будет.
  • Новая иконка и логотип в виде светофора.
  • Поддержка языковых плагинов.
  • Добавлено главное меню.

  • 12 методов обнаружения процессов.
  • Каждый процесс оценивается программой по степени опасности (безопасный, системный, подозрительный, опасный, обычный).
  • Возможность из меню остановить, продолжить процесс, убить процесс и его файл.
  • Поддержка только для Windows 2000/XP.
    Copyright (C) 2006-2012, System SoftLab.
    Дата последнего обновления


Всегда рады ответить на ваши вопросы. Выберите адрес из списка ниже и задайте свой вопрос. Если вы зарегистрированный пользователь укажите в письме свой регистрационный номер и имя.

  • spydetector@systemsoftlab.com
    Техническая поддержка программы Spyware Process Detector.

  • sales@systemsoftlab.com
    Вопросы по оплате, приобретению, скидкам, запросы на получение паролей и ключей.

  • general@systemsoftlab.com
    Вопросы по размещению рекламы и сотрудничестве, деловые предложения.

Copyright (C) 2006-2012, System SoftLab.
Дата последнего обновления